No fuel injector pulse (stranded, please help)

Questions or problems on your Lesharo.

No fuel injector pulse (stranded, please help)

Unread postby tom » Sat Oct 17, 2020 2:57 pm

Hello everyone. Brand new to the forum. Purchased an 87 Itasca and have spent the past year getting it in shape. Its maiden voyage is a 3000 plus mile trip from Niagara Falls to Vancouver Island. Ran great until 15 miles from the Vancouver ferry terminal. So close.
The only problem I had on the trip was the fuel pump cavitating and engine sputter on hills when the tank was getting low. Would run great again on next downhill. Top up with gas all is well again.
15 miles from the ferry, sputtering started and I tried to get off the highway to gas up. Got worse in traffic and finally died with a poof on a very steep off ramp.
After a tow and gassing up, the engine would fire but die quickly. As time went on it would fire a little longer. Thought the fuel pump was toast. I disconnected the ground (white wire) from the pump and hooked up an external battery. Pump worked! Tried to start it again and it fired as usual but died in about 3 seconds. I next checked for pressure at the fuel rail. Good. Stumped.
Bingo! I noticed the main intake hose was coming off. Must have came off with the poof when it first died. Replaced the hose and wire on the pump and tried to start expecting good results. Wouldn't even fire now. Finally found I now have no pulse at the injectors. Tried the bypass fix found on this site but no luck.
Is is possible I blew something when trying to start with an external battery hooked to the pump (white wire was removed from pump)? What other reasons could there be for suddenly loosing injector pulse? Any help would be appreciated. Thank you.
Tom
User avatar
tom
 
Posts: 1
Joined: Sat Oct 17, 2020 12:14 am


  • Similar Topics
    Replies
    Views
    Last post

Return to Questions and problems

Who is online

Users browsing this forum: No registered users and 1 guest